Home > Installation > CodeRush/IDE Tools system requirements

CodeRush/IDE Tools system requirements

May 30th, 2012

This is another frequent question from new CodeRush users, which is not exactly specified anywhere yet because CodeRush does not really rely on hardware or software requirements – it should run OK everywhere your Visual Studio is installed.

Supported Operating Systems

CodeRush supports any operating system no matter whether it is 32 or 64 bits with Visual Studio installed.

Supported Visual Studio versions

The latest version of CodeRush supports Visual Studio versions starting from 2008. You can request previous product versions that work with earlier versions of Visual Studio from the DevExpress Support Team.

Visual Studio Express editions are not supported, because these versions do not support extensibility.

However, it is recommended that your Visual Studio has all latest service packs installed.

Hardware requirements

CodeRush does not require a lot of memory installed on your computer and does not need a high-speed processor. The following blog post from Mark Miller may better describe the CodeRush system impact in regard to memory and performance consumption:

Performance and Memory Milestones in CodeRush and Refactor! Pro

Products: all
Versions: 11.2 and up
VS IDEs: 2008 and up
Updated: May/30/2012
ID: T057

Similar Posts: